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About this Book 
This free eBook is the first in a series of four that will be released to our Excelguru email newsletter 
subscribers. Each book contains five of our favourite tips, tricks, and techniques, with one book each for 
Excel, Power Query, Power Pivot, and Power BI. The tips and tricks shared in these books have been 
developed over years of research and real-world experience. 

 

 

 

Get the Entire Series 
Don’t miss out on the other three books in this series. They’re all free, and you can get them as a reward 
for subscribing to the Excelguru newsletter. In addition to the free book, you’ll also get our monthly(ish) 
email newsletter features the latest updates for Excel and Power BI, upcoming training sessions, new 
products, and other information.  

If you are not already a subscriber, sign up today at http://xlguru.ca/newsletter. 
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Tip 1: Easiest Formula to Return the End of the Month 
Dates form a big part of many of the Excel analysis and business intelligence solutions that I build. One 
thing I can tell you for certain, is that when you deal with accountants, providing any old date isn’t 
sufficient. We want reports shown based on the last day of the month in about 99% of cases. 

The easiest way to get the month end date in Excel is to use the EOMONTH() function. It’s been in Excel 
for a long time, although in versions prior to Excel 2007 you had to activate the Analysis Toolpack add-in 
to expose it. 

So what is this function, and how do we use it?  It looks like this: 

=EOMONTH(start_date,months) 

The real trick to this function is all about the last parameter, as that is which month end you get. It works 
like this: 

• -x: End of month x month(s) ago 

• 0: The end of the current month 

• x: End of month plus x month(s) 

And the best part is that it is February 28/29 aware.  Here’s some samples: 

Cell A1 Contains This Formula Will Yield 

2017-01-15 =EOMONTH(A1,0) 2017-01-31 

2017-01-15 =EOMONTH(A1,-2) 2016-11-30 

2017-01-15 =EOMONTH(A1,4) 2017-05-31 

2016-02-15 =EOMONTH(A1,0) 2016-02-29 

2016-02-15 =EOMONTH(A1,12) 2017-02-28 

 
With this function, you can also pick up the end of the current year or even next year with a slight 
modification: 

Current Year Next Year 

=EOMONTH(TODAY(),12-MONTH(TODAY())) =EOMONTH(TODAY(),24-MONTH(TODAY())) 

 
And likewise, we can even get the beginning of the current or former year with the following: 

Current Year Previous Year 

=EOMONTH(TODAY(),-MONTH(TODAY()))+1 =EOMONTH(TODAY(),-MONTH(TODAY())-12)+1 

 
This function is useful not only for schedules and analysis, but can also form the base calculation for 
building calendar tables. 
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Tip 2: Show Message if Your Pivot Data is Stale 
One thing that has saved my bacon many times is the creation of an error checking section for my model. 
The more complicated the model, the more this is necessary, but you’ll find the main effort is worth it 
even for small models. And one key area is around recognizing if the source data for a PivotTable has been 
updated. 

Imagine we have the report shown below: 

 

Figure 1 - A report based on a Pivot Table and Pivot Chart 

How do you know that the Pivots are up to date? The simple answer is, “You don’t”. So why don’t we fix 

that by adding a simple error checking section above the report? Something that looks like this: 

 

Figure 2 - A simple error checking section 

The Data Table 
One caveat I will throw out here is that my data is based on an Excel table which I called “Data”, as shown 

in Figure 3, below. Note that this is not just a tabular range. (If you click in your data and don’t see the 

Table Tools tab pop up, it’s just data, so press CTRL+T to fix it.) The reason for this is that tables 

automatically expand as new data is added, a huge benefit for keeping both your formulas and Pivot 

Tables up-to-date. 
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Figure 3 - The "Data" Table 

The Error Check Pivot 
Before we lay out the error check table, we do need to create another very simple Pivot Table that shows 

our summary statistics. This is done by creating a new Pivot Table from the Data source and then dragging 

the Item and Total Sale columns into the Values area: 

 

Figure 4 - PivotTable used for summary statistics 

Where you put this pivot is up to you. It can even be hidden on a different worksheet if you like. I put mine 

on a worksheet called “Validation” starting in A3. 

The Error Check Table 
We can finally lay out the error check table shown in Figure 5: 

 

Figure 5 - The error check table 
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I generally like to put this at the very top of my worksheet above the report headers so that I can always 
see it. 

Here is the makeup for the formulas: 

• Per Data: Sales Items: 

=COUNTA(Data[Item]) 

• Per Data: Total Sales $: 

=SUM(Data[Total Sale]) 

• Per Pivot: Sales Items: 

=GETPIVOTDATA("Count of Category",Validation!$A$3) 

• Per Pivot: Total Sales $: 

=GETPIVOTDATA("Sum of Total Sale",Validation!$A$3) 

• Difference formulas are “Per Data” – “Per Pivot” except for the last, which is just a sum of the cells 
above 

And finally, we come to the cell that reads “Pivots are up to date”. This is actually an IF statement that 
was created as follows: 

=IF(E4<>0,"Source data has changed!","Pivots are up to date") 

And with a tiny bit of conditional formatting magic, it becomes pretty obvious that the source data has 
changed but we have forgotten to update our Pivot Table: 

 

Figure 6 - Alert!  Your Pivots are out of date! 

Be aware that you should test your error checking aggregations. You may want more columns included, 

and you may also need to modify the tests if you have both positive and negative values (as the variances 

could cancel each other out, resulting in a 0 difference at the end.) 

I will say that properly constructed tests are worth its weight in gold since it makes it very obvious when 

something goes wrong.  I highly recommend taking the time to implement this technique.  
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Tip 3: Show Message When Cells are Hidden 
The reality is that you don’t always need to see your assumptions, error checking or parameter tables. 
And while you could just hide those rows, it’s not super obvious to someone else that you’ve done so. 

My preferred method for dealing with this issue is to use a combination of techniques to allow hiding the 
rows when I don’t need them, but also to make it easy for my user to both recognize and unhide the rows 
when needed. To do this, I use a combination of the outlining tools and an IF statement to react to a 
formula that counts visible cells. 

Here’s a look at an assumption section that you might find at the top of one of my models: 

 

Figure 7 - Assumptions on display 

And when I click the – button on the left, it collapses to look as follows: 

 

Figure 8 - Assumptions are out of the way for the moment 

There are two parts to setting this up: 

1. Creating the grouping outline 

2. Creating the formula 

Part 1: Creating the grouping outline 
If you’ve never used grouping before, this part is deceptively simple. You just need to: 

• Select rows 3:6 

• Go to Data → Outline → Group 

Upon doing so, the worksheet should now look as shown in Figure 7. 

The only real trick to understand here is that the expand/collapse (+/-) row is always created as the row 

immediately following your selection. 
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Part 2: Creating the formula 
The next trick is creating the formula that counts the visible rows, which is shown below: 

=IF( 

SUBTOTAL(103,A3:A6)=0, 

"<-- Click here to show assumptions", 

"" 

) 

Like every IF function, there are three parts: the logical test, what we want if the test is true, and what we 

want if the test is false. 

The logical test here makes use of the SUBTOTAL function to count the number of cells in A3:A6 that 

contain text. The first parameter for the SUBTOTAL function is “function_num”, and the secret here is that 

we don’t want to use function 3 for our COUNTA, we actually want to use 103. 

 

Figure 9 - Choosing how the SUBTOTAL function calculates its value 

Even though both function 3 and 103 show as COUNTA, the difference is that all of the functions in the 

100’s only count visible cells. As the cells are no longer visible when the grouping level is collapsed, we 

can set up a simple test to see if the count of visible cells in the grouping area is 0. If it is, the section must 

be collapsed. 

With the test set up, we then need to tell Excel what we’d like to see in the cell if the rows are all collapsed. 

As we’d like to see some text, we simply wrap our desired phrase in quotes. This could be anything, but 

personally I’m a big fan of creating an arrow that points right to the button that needs to be clicked to 

show the range. 

Finally, we come to the output we want to see if the area is expanded. In the case of the provided formula, 

the “” will return a blank. (Everything between the quotes – which is nothing – will be returned to the 

cell.) Depending on your model, you may wish to have a message here like, “Insert new assumptions 

above this cell” or something. That’s completely your call. 

And that’s it. Super easy, but very powerful. I use this technique often to collapse my assumptions areas, 

but also to hide the detail for the error checking sections of my models. 
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Tip 4: Quick Alignment of Objects 
I’m not 100% sure about other people out there, but one thing I do know for certain is that finance people 
tend to be rather… particular... about how things look. When I present Excel sessions to finance pros, I 
always ask how many of them spend hours lining up charts, slicers and other objects on their worksheets 
to make sure that they line up perfectly level. 

It always earns a chuckle, as we all do it, but unfortunately most of us are handling this task in a very 
manual method. If you’ve done this, you know just how hard it is to try and move a slicer or a chart up 
one pixel with the mouse. And then trying to get each slicer the same height… yikes! 

Let’s look at an example. Figure 10 has two slicers and a chart: 

 

Figure 10 - How would you line these up? 

How would you go about making sure that: 

• The left borders of the Month slicer and the chart are aligned, and 

• The right borders of the Animal slicer and the chart are aligned, and 

• The top borders of the slicers are aligned, and 

• Both slicers are the same height? 

The good news is that there is a better way than manually dragging each item and trying to trace invisible 
lines. 

Quick Alignment 
Let’s align the objects first: 

• Select the Month slicer by clicking its header 

• Hold down the CTRL key and select the Animal slicer (they should both be selected now) 

• Go to Slicer Tools → Align → Top 

And yes, it’s just that easy! 



  

8 ‘DIY BI’ Tips, Tricks & Techniques 

 

Remember that holding down your CTRL key allows you to select multiple non-contiguous objects. (Unlike 
the Excel grid, however, holding down CTRL and clicking the object again un-selects it.) 

The alignment commands can be found on the Drawing tab as well, so if you are picking up different types 
of objects (like Charts, Slicers or Shapes), you can still align them.You’ll also notice that you have the 
option to align Left, Right, Top of Bottom, the only trick to know here is that it aligns to x-most item that 
you have selected. 

Controlling Object Height/Width 
I find that a lot of people overlook the fact that the sizes of our objects are actually displayed on the ribbon 
tabs. It may be due to the fact that we are used to dragging things around, it may be that there is just so 
much stuff to learn. Regardless, to get our slicers the same height, all we need to do is this: 

• Select the Month slicer 

• Check its height on the right side of the Slicer Tools tab 

• Select the Animal slicer and change its height to match 

 

Figure 11 - Changing object sizes 

It’s also worth noting that other objects also show their sizes on the ribbon, and can be changed there as 

well. Charts, for example, have their sizes on the Chart Tools → Format tab 

 

Figure 12 - Everything all lined up and perfect!  
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Tip 5: Easy to Read Variances 
One of the cruelest things an accountant can do to someone who doesn’t have a financial background is 
to provide them with a statement that looks similar to this: 

 
Figure 13 - A horrible financial statement 

At this point the poor manager needs to try and run the mental mathematics on the variance column to 

figure out if positive is good or bad, and if the rule holds true for revenues and expense. (Revenue lower 

than budget is bad, expenses lower than budget is good.) The challenge here is that the formula is not 

consistent between revenues and expenses (the sign needs to be flipped), and that is not always done. 

I hated watching my users play the mental gymnastics game, so I decided to apply a trick from cost 

accounting with Excel. I probably freaked out a bunch of our newer managers, as they would get 

presented with this statement on a monthly basis instead: 

 

Figure 14 - A financial statement with easy to read variances 

This first time I would do this for each manager it was delivered with a cheerful, “Here’s your statement.  

Now, let me tell you why it says eff-you all over it.” This was followed with a discussion of how we 
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represented our numbers using F for Favourable and U for Unfavourable. And guess what? They never 

had to do mental gymnastics on our statements. 

How do you do this? 
We take advantage of a custom number format. To do this: 

• Select the cells → right click → Format Cells 

• Go to the Number tab → Custom 

• Enter the following custom number format:   

#,##0 F; #,##0 U; "-  " 

• Click OK twice and you’re done 

So, how does it work? 
There are four potential components to a custom number format, each separated by a semi-colon. Those 
are: 

• Positive Numbers 

• Negative Numbers 

• Zeros 

• Text 

So, in this case, you get: 

• Positive numbers: #,##0 F 

• Negative numbers: #,##0 U 

• Zeros:   "-  "  (quote, dash, space, space, quote) 

• Text:   omitted 

And this is what the characters mean: 

• # Show a number if one exists for that placement, otherwise omit it 

• , Thousands (and higher) separator 

• 0 Show in a 0 even if no number is needed for that position 

• Space A space 

• F & U Letters (sometimes need to be wrapped in quotes) 

• “-   “ Everything between the quotes is returned to the cell 

The biggest key here, however, is that we are not converting the values to text. If you look in the formula 
bar they are still numbers, meaning you can perform any mathematics upon them if needed. 

Custom number formats can be useful for many things such as: 

• Displaying dates in an ISO format:  yyyy-mm-dd 

• Displaying UPC codes with leading zeros: 0000-0000-0000-0000 

And many more.  

For more on custom number formats, check out my friend Jon Peltier’s great article on the subject:  
http://peltiertech.com/Excel/NumberFormats.html 
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Extend Your Learning 
If you are interested in learning all  

the core skills for the Excel analyst  

(including formulas and functions,  

PivotTables, data visualizations,  

and Power Query), check out  

our online training: 

Excel Fundamentals Boot Camp 

 

 

https://skillwave.training/shop/excel-fundamentals-bc/
https://www.powerquery.training/shop/power-query-academy/
https://skillwave.training/shop/excel-fundamentals-bc/
https://skillwave.training/shop/excel-fundamentals-bc/
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